通达信雄鹰冲天指标公式(图文)

时间:2019-10-20 12:01:34 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

N:=90;
M1:=3;
M2:=3;
N1:=10;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖: 3.2,COLORC6C600;
清仓:3.5,COLORFF75FF;
动力线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLOR70DB93;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖,动力线),20),动力线+0.02,2);
界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;
数值:=动力线;
最佳买入:ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)DRAWTEXT(最佳买入=1,2.3,'买入'),COLORYELLOW;
ZYX1:="DMI.PDI"(12,6);
ZYX2:="DMI.MDI"(12,6);
ZYX3:=ZYX1>65 AND ZYX1>REF(ZYX1,1);
ZYX4:=LLV(ZYX1,0);
ZYX5:=BARSLAST(ZYX4=ZYX1);
ZYX6:=(0-REF(ZYX2,4))/(ZYX4-REF(ZYX2,ZYX5))>2;
ZYX7:=ZYX1>REF(ZYX1,1);
ZYX8:=VOL>2*MA(VOL,30);
ZYX9:="DMI.ADX"(12,6);
ZYXA:="DMI.ADXR"(12,6);
ZYXB:=CLOSE>MA(CLOSE,30) AND CLOSEZYXC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
ZYXD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))ZYXF:=TROUGHBARS(3,15,1)<4;
ZYX10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
ZYX11:=IF(ZYXF=1,50,0);
ZYX12:=CROSS(ZYX2,ZYX1) AND CROSS(ZYXA,ZYX9);
ZYX13:=CROSS(ZYX2,ZYX1) AND CROSS(ZYX9,ZYXA);
ZYX14:=ZYXB AND ZYXC AND ZYXD AND ZYX10 AND ZYX6 AND ZYX7 AND ZYX8*50;
ZYX15:=BARSLAST(CROSS(ZYX2,ZYX1)=1);
ZYX16:=BARSLAST(CROSS(ZYX1,ZYX2)=1);
ZYX17:=HHV(ZYX1,ZYX16);
ZYX18:=BARSLAST(ZYX1=ZYX17);
多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
STICKLINE(FILTER(ZYXF=1,5) AND 多空<-10,2.5,0.5,3,0),COLORRED;
STICKLINE(FILTER(ZYXF=1,5),2.5,0.5,1,0),COLORRED;
ZYX19:=ZYX3 OR ZYX12 OR ZYX13*100;
ZYX1A:=ZYX13*100;
DRAWTEXT(FILTER(ZYXF=1,3),1.3,'-铁底'),COLORYELLOW;
A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
短多:=IF(A1>=B1,A1,B1);
短空:=B1;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
RSI4:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI5:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI6:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI7:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI8:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
RSI9:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI10:=SMA(MAX(CLOSE-LC,0),11,1)/SMA(ABS(CLOSE-LC),11,1)*100;
RSI11:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI12:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSI13:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
RSI14:=SMA(MAX(CLOSE-LC,0),15,1)/SMA(ABS(CLOSE-LC),15,1)*100;
RSI15:=SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100;
RSI16:=SMA(MAX(CLOSE-LC,0),17,1)/SMA(ABS(CLOSE-LC),17,1)*100;
RSI17:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
RSI18:=SMA(MAX(CLOSE-LC,0),19,1)/SMA(ABS(CLOSE-LC),19,1)*100;
RSI19:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
RSI21:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
RSI30:=SMA(MAX(CLOSE-LC,0),30,1)/SMA(ABS(CLOSE-LC),30,1)*100;
RSI40:=SMA(MAX(CLOSE-LC,0),40,1)/SMA(ABS(CLOSE-LC),40,1)*100;
RSI50:=SMA(MAX(CLOSE-LC,0),50,1)/SMA(ABS(CLOSE-LC),50,1)*100;
RSI60:=SMA(MAX(CLOSE-LC,0),60,1)/SMA(ABS(CLOSE-LC),60,1)*100;
RSI70:=SMA(MAX(CLOSE-LC,0),70,1)/SMA(ABS(CLOSE-LC),70,1)*100;
RSI80:=SMA(MAX(CLOSE-LC,0),80,1)/SMA(ABS(CLOSE-LC),80,1)*100;
RSI90:=SMA(MAX(CLOSE-LC,0),90,1)/SMA(ABS(CLOSE-LC),90,1)*100;
RSI100:=SMA(MAX(CLOSE-LC,0),100,1)/SMA(ABS(CLOSE-LC),100,1)*100;
RSI110:=SMA(MAX(CLOSE-LC,0),110,1)/SMA(ABS(CLOSE-LC),110,1)*100;
RSI120:=SMA(MAX(CLOSE-LC,0),120,1)/SMA(ABS(CLOSE-LC),120,1)*100;
短线RSI:=(RSI1+RSI2+RSI3+RSI4+RSI5)/5,COLORWHITE;
中线RSI:=(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15;
长线RSI:=(RSI21+RSI30+RSI40+RSI50+RSI60+RSI70+RSI80+RSI90+RSI100+RSI110+RSI120)/11;
A:=CROSS(短线RSI,中线RSI);
B:=CROSS(中线RSI,短线RSI);
A11:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A21:=LLV(L,21);
A31:=LLV(L,30);
A41:=EMA(A11,5);
A51:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
基础:=DIFF<-0.1 AND DIFF>DEA;
中线买入:=CROSS(A11,A41) AND (A51-A41)>40 AND 基础;
STICKLINE(中线买入,0.5,1.75,1,0),COLORMAGENTA;
DRAWTEXT(中线买入,1.75,'-冲天'),COLORYELLOW;
BW1:=C>REF(C,1) AND C>REF(C,2);B2:=REF(BW1,1) AND C<=REF(C,1) AND C>=REF(C,2);
B3:=REF(B2,1) AND C>=REF(C,1) AND C<=REF(C,2);JJ:=(C*3+H+L+O)/6;
B4:=REF(B3,1) AND C<=REF(C,1) AND C>=REF(C,2);ZZ:=(EMA(JJ,13)-EMA(JJ,21))*180;
B5:=REF(B4,1) AND C>=REF(C,1) AND C<=REF(C,2);SS:=EMA(ZZ,2);GG:=(ZZ-SS)*0.001;
B6:=REF(B5,1) AND C<=REF(C,1) AND C>=REF(C,2);VV:=-1*(ZZ-SS)*0.001;
B7:=REF(B6,1) AND C>=REF(C,1) AND C<=REF(C,2);XC:=CROSS(GG,VV);
B8:=REF(B7,1) AND C<=REF(C,1) AND C>=REF(C,2);DZ:=CLOSE>REF(CLOSE,1)*1.032;
B9:=REF(B8,1) AND C>=REF(C,1) AND C<=REF(C,2);EE:=(H-C)/C*100<0.5;
BA:=REF(B9,1) AND C<=REF(C,1) AND C>=REF(C,2);X1:=IF(C>O,C,O);X2:=IF(C>O,O,C);
BB:=REF(BA,1) AND C>=REF(C,1) AND C<=REF(C,2);SYX:=H-X1;XYX:=X2-L;
BC:=REF(BB,1) AND C<=REF(C,1) AND C>=REF(C,2);PG:=SYXBD:=C=REF(C,1) AND C<=REF(C,2);
BF:=REF(BE,1) AND C<=REF(C,1) AND C>=REF(C,2);CC:=REF(C>O,1) AND C>O;
B10:=REF(BF,1) AND C>=REF(C,1) AND C<=REF(C,2);MACD:="MACD.MACD";
B11:=REF(B10,1) AND C<=REF(C,1) AND C>=REF(C,2);FF:=V<=LLV(V,6) OR V>=HHV(V,6);
B12:=REF(B11,1) AND C>=REF(C,1) AND C<=REF(C,2);B13:=REF(B12,1) AND C<=REF(C,1) AND C>=REF(C,2);
B14:=REF(B13,1) AND C>=REF(C,1) AND C<=REF(C,2);B15:=REF(B14,1) AND C<=REF(C,1) AND C>=REF(C,2);
B16:=REF(B15,1) AND C>=REF(C,1) AND C<=REF(C,2);B17:=REF(B16,1) AND C<=REF(C,1) AND C>=REF(C,2);
B18:=REF(B17,1) AND C>=REF(C,1) AND C<=REF(C,2);
QQ:=REF(BD OR BE OR BF OR B10 OR B11 OR B12 OR B13 OR B14 OR B15 OR B16 OR B17 OR B18,1) AND BW1;BL:=C>MA(C,10) AND MA(C,10)>=REF(MA(C,10),1) AND MACD>REF(MACD,1);
追击:=QQ AND XC AND EE AND DZ AND PG AND CC AND BL AND FF;
STICKLINE(追击,0.5,2.8,1,0),COLORCYAN;
DRAWTEXT(追击,2.8,'-追击'),COLORYELLOW;

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)