超级指标1,超级指标可以查主力资金的(通达信公式 主图 源码 测试图)(图文)

时间:2020-03-01 22:47:10 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

超级指标:1

 

 

拉升:IF(CURRBARSCOUNT=1 AND REF(C,1)<REF(C,2) AND C>REF(C,1) AND MA1>REF(MA1,1),CONST(REF(C,1)*1.01),DRAWNULL),COLORFF00FF;

A001:STICKLINE(CURRBARSCOUNT=1 AND C>=REF(C,1),拉升,拉升*0.9992,15,0),COLORMAGENTA;

DRAWTEXT(CURRBARSCOUNT=1 AND 拉升=CONST(REF(C,1)*1.01),L*0.99996,'      拉升线'),COLORMAGENTA;

DRAWKLINE(H,拉升,L,C);

 

止损:REF(HHV(H,13),1)*0.95,COLORGREEN,DOTLINE;

A002:STICKLINE(CURRBARSCOUNT=1 AND C>=REF(C,1),止损,止损*0.9996,15,0),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=1,止损*0.996,'止损线'),COLORGREEN;

 

 

DRAWKLINE(H,O,L,C);

ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);

ZSP:=IF(C>REF(C,1),C,DRAWNULL);

DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);

DSP:=IF(C<=REF(C,1),C,DRAWNULL);

DRAWKLINE(H,DKP,L,DSP);

STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;

STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;

STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;

STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;

DRAWKLINE(H,ZKP,L,ZSP);

STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;

STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;

STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;

STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;

STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;

VAR111:=ZIG(3,13);

STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;

DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;

 

MA5:MA(C,5)LINETHICK3,COLOR00CCFF;

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

 

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1);

B1:=FILTER(A1,10);

C1:=BACKSET(B1,10+1);

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1);

B2:=FILTER(A2,10);

C2:=BACKSET(B2,10+1);

LD:=FILTER(C2,10);

前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;

STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;

JRH:=HHV(C,2);     

JRL:=LLV(C,2);     

VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));     

VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));  {GUPIAOFF.COM}   

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     

VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     

VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);     

VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);     

红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

离场:=IF(红色持股,JRL,DRAWNULL);     

明离场价:=离场,COLORFF99FF,NODRAW;

青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;     

进:=IF(青色观望,JRH,DRAWNULL);

今离场价:REF(离场,1),COLOR0000FF,NODRAW;     

明进场价:=进,COLOR33AACC,NODRAW;     

今进场价:REF(明进场价,1),COLORGREEN,NODRAW;

上涨家数:INDEXADV,COLOR0080FF,NODRAW;

下跌家数:INDEXDEC,COLORGREEN,NODRAW;

 

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.97,5) ;

DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.03,6);

 

五日乖离率:=(C-MA5)/MA5*100;

BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;

IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED;

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORGREEN;

三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);

加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);

清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);

DRAWTEXT(加仓 ,LOW*0.96,'加'),COLORYELLOW;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.01,'←风险'),COLORCYAN;

DRAWTEXT(买入,LOW*0.99,'买'),COLORYELLOW;

DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;

DRAWTEXT(强势狙击,LOW*0.98,'←狙击'),COLORWHITE;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

压力:MA(REF(HHV(C,30),1),2),COLORABFF46;

支撑:MA(REF(LLV(C,30),1),2),COLOR9DFFFF;

 

 

DRAWTEXT_FIX(C>0,0.0,0.0,0,STRCAT('所属行业:',HYBLOCK)),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.10,0.0,0,STRCAT('所属地区:',DYBLOCK)),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.20,0.0,0,STRCAT('主题投资:',GNBLOCK)),COLORYELLOW;

DRAWTEXT_FIX(1,0.00,0.05,0,'业绩预报:')COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,11))COLORYELLOW;

{DRAWTEXT_FIX(C>0,0.00,0.10,0,STRCAT('业绩预报:',EXTERNSTR(0,3))),COLORYELLOW;}

{DRAWTEXT_FIX(C>0,0.0,0.15,0,STRCAT('解禁日期:',EXTERNSTR(0,8))),COLORYELLOW;}

{DRAWTEXT_FIX(C>0,0.00,0.20,0,STRCAT('千股千评:',EXTERNSTR(0,1))),COLOR00FFFF;}

{DRAWTEXT_FIX(C>0,0.00,0.25,0,STRCAT('智能诊股:',EXTERNSTR(0,2))),COLOR00FFFF;};

 

 

 

T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);

T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);

T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);

T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);

T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);

T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);

T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);

T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);

T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);

T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);

DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;

T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);

T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);

T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);

T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);

T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);

T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);

T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);

T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);

T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);

TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);

DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;

T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0);

T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);

T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);

T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);

T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);

T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);

T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);

T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);

T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);

TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);

DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

 

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

VAR113:=HHV(HIGH,60);

VAR114:=LLV(LOW,30);

VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR116:=(VAR113+VAR114+VAR115)/3;

VAR117:=EMA(VAR116,5);

K01:=EMA(VAR117,5)*2, COLORFF00FF;

D01:=EMA(K01,5),  COLORWHITE;

J01:=K01*3-D01*2, COLORYELLOW;

ENTERLONG:=CROSS(K01,D01);

EXITLONG:=CROSS(D01,K01);

B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;

B02:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);

必买:=(B01 AND B02) AND 净流入>0;

必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;

QQ:=必卖=80;

B03:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));

V1:=EMA(CLOSE,60)-EMA(CLOSE,300);

V2:=EMA(V1,300);

V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;

V4:=SMA(V3,2,1),NODRAW;

V5:=SMA(V4,2,1),NODRAW;

V6:=CLOSE/REF(CLOSE,3)>=1.1;

V7:=BACKSET(V6,3);

大涨:=(V7 AND COUNT(V7,3)=1);

DRAWICON(必买,L-0.16,11);

DRAWICON(大涨 AND 必买,L-0.16,9);

DRAWICON(大涨,L-0.18,1);

{DRAWICON(QQ,H+0.1,6);}

 

DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=L2_AMO(0,3)/10000.0;

大S:=L2_AMO(1,3)/10000.0;

中S:=L2_AMO(2,3)/10000.0;

小S:=L2_AMO(3,3)/10000.0;

TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

大宗进:=(超B)+(大B),NODRAW;

大宗出:=(超S)+(大S),NODRAW;

非大宗进:=(中B)+(小B),NODRAW;

非大宗出:=(中S)+(小S),NODRAW;

大宗进限制:=IF((超B+大B)=0,0,大宗进);

大宗出限制:=IF((超S+大S)=0,0,大宗出);

非大宗进限制:=IF(中B+小B=0,0,非大宗进);

非大宗出限制:=IF(中S+小S=0,0,非大宗出);

主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;

净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;

连续流入:EVERY(净流入>0,2),NODRAW;

 

大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;

大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);

总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;

大单强度限制:=IF(大单强度=0,-100,大单强度);

大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;

超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;

超单强度限制:=IF(超单强度=0,-100,超单强度);

超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

{分析家公式网www.70822.com 修改好的源码,可以编成公式,请下载公式}

DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;

DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;

DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;

主力买力度:=LARGEINTRDVOL*1000/VOL;

主力卖力度:=LARGEOUTTRDVOL*1000/VOL;

AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

{DDE显示}

DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);

DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);

DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);

DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;

DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;

DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;

 

 


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)