缠论三买选股公式主图改编【实用精准】(图文)

时间:2019-12-16 09:57:13 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

缠论三买选股公式是由主图改编而来,我用了很长时间,可能电脑出问题里面的东西全没了,我又在操盘手公式网找到这份指标,请高手改编一个买点选股公式,我觉得【实用精准】 。

KX:='CHANLUN@KXIAN';
KXG:='CHANLUN@KXG';
KXD:='CHANLUN@KXD';
KXFX:='CHANLUN@KXFX';
笔:='CHANLUN@BI';
笔周期:'CHANLUN@BILAST',LINETHICK1, COLORFF00FF;
BILAST:='CHANLUN@BILAST';{笔周期};
段:='CHANLUN@DUAN';
段周期:'CHANLUN@DUANLAST', LINETHICK1, COLORFFFFFF;
DUANLAST:='CHANLUN@DUANLAST'; {段周期};
中枢:='CHANLUN@ZS';
ZSZG:='CHANLUN@ZSZG';
ZSZD:='CHANLUN@ZSZD';
ZSGG:='CHANLUN@ZSGG';
ZSDD:='CHANLUN@ZSDD';
ZSZZ:='CHANLUN@ZSZZ';
ZSKS:='CHANLUN@ZSKSLAST';
ZSJS:='CHANLUN@ZSJSLAST';
BIFX:=-REF(笔,BILAST);
DUANFX:=-REF(段,DUANLAST);  
KXQJ:='CHANLUN@KXQJ';
{画中枢BEGIN} {以背景方式画}
STICKLINE(ZSZG>ZSZD AND DUANFX=1, ZSZG, ZSZD, 10, 1),COLOR8E236B;
STICKLINE(ZSZG>ZSZD AND DUANFX=-1, ZSZG, ZSZD, 10, 1), COLOR007700;
{中枢震荡监视器}{操盘手公式网-最牛股票公式学习网站 www.stock87.com}
DRAWLINE(ZSKS=1, ZSZZ, ZSJS=1, ZSZZ, 0), COLORFFFFFF;
{画中枢END}  
{顶底分型}
STICKLINE(KX>0, KXG, KXD, 5, 1),COLOR007700,LINETHICK2;
STICKLINE(KX<0, KXG, KXD, 5, 1),COLOR00FFFF,LINETHICK2;
{笔段}
STICKLINE(笔=1, KXG, KXD, 5, 1), COLORGREEN, LINETHICK2;
STICKLINE(笔=-1, KXG, KXD, 5, 1), COLORRED, LINETHICK2;
STICKLINE(段=1, KXG, KXD, 5, 0), COLOR007700, LINETHICK2;
STICKLINE(段=-1, KXG, KXD, 5, 0), COLOR0000CC, LINETHICK2;
{画K线END}
{画笔段}
DRAWLINE(笔=1,H,笔=-1,L,0),COLORBLUE,LINETHICK2;
DRAWLINE(笔=-1,L,笔=1,H,0),COLORFF00FF ,LINETHICK2;
DRAWLINE(段=1,H,段=-1,L,0),COLOR007700, LINETHICK2;
DRAWLINE(段=-1,L,段=1,H,0),COLORRED, LINETHICK2;

{笔高低点 周期 力度 提示}
DRAWTEXT(笔=1, H*1.038,H),COLORRED;
DRAWTEXT(笔=-1, L*0.96, L),COLORFFFFFF;
VAR3:=LLV(H,240);
VAR4:=100*(C-VAR3)/VAR3;
VAR5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
VAR6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND H>L+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);{操盘手公式网-最牛股票公式学习网站 www.stock87.com}
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(C,2)-EMA(C,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,L*0.985,'买'),COLOR00FFFF;
DRAWTEXT(卖1>0,H*1.01,'卖'),COLOR00FFFF;
APP:=(VOL)/((H-L)*(2)-ABS(C-O));
ZL:=IF((H>O),(APP)*(H-L),IF((L<O),(APP)*(H-O+C-L),(VOL)/(2)));
SF:=IF((H>O),0-(APP)*(H-C+O-L),IF((L<O),0-(APP)*(H-L),0-(VOL)/(2)));
库存能量:=MA(ZL+SF,2);
库存平均:=MA(ZL+SF,5);
GET:ZIG(3,5),COLORYELLOW,LINETHICK3;
PL5:=ZIG(3,5);
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
PL10:=ZIG(3,10);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
PL20:=ZIG(3,20);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'[类二买]'),COLORFFFFFF;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'[一买]'),COLORFF00FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.04,'[二卖]'),COLORFFFF00,LINETHICK2;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'[二买]'),COLORFFFF00,LINETHICK2;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.03,'[一卖]'),COLOR00FF00,LINETHICK3;

DRAWTEXT_FIX(ISLASTBAR,0.15,0.029,0,'历史最高价='),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.058,0,'历史最低价='),COLORAFFF00;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.087,0,'20日最高价='),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.15,0.116,0,'20日最低价='),COLORAFFF00;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.029,0,HHV(HIGH,0)),COLORFF00FF;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.058,0,LLV(LOW,0)),COLORAFFF00;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.087,0,HHV(HIGH,20)),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.199,0.116,0,LLV(LOW,20)),COLORAFFF00;



后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)